Resolved | Oct 21, 2025 | 08:15 GMT-04:00
We continue to observe recovery across all services
Investigating | Oct 20, 2025 | 11:30 GMT-04:00
We have identified an incident that our Search is currently down, post AWS outage. We are working with our technology partners and currently investigating.